Lyman 20lb may have died

  • 501 Views
  • Last Post 3 hours ago
Richard Pickering posted this 3 weeks ago

Last week the Lyman 20 began freezing at the spout. I initially thought of zinc contamination as I was using alloy from a friend's accumulation.  I drained it and cleaned the pot bottom. Today I intended to warm it and possibly cast a bit. 

After having it on for several minutes it had failed to feel warm. This one is at least 30 years old but of course it doesnt get used every day. And the question is----How many have had the electric furnace fail ?  Did the element go open or was the demise from another cause ?  Do you know if Lyman has replacement parts ?

It seems exploratory surgery is in order.  

Thank you. Richard 

Attached Files

Order By: Standard | Newest | Votes
GWarden posted this 2 weeks ago

Richard

I'm not sure if Lyman will send the parts. I had the element go out on a Lyman furnace and they had me send it in and replaced it, that has been probably 5 years ago and still working fine. 

bob

Attached Files

Richard Pickering posted this 2 weeks ago

GWarden, I sent Lyman an email via their site and asked if they will send one. I'll post their reply. Thank you. 

Richard 

Attached Files

Wm Cook posted this 2 weeks ago

Hope they can do the repairs. Good luck. If it’s worse case, what would you replace it with?

Attached Files

Richard Pickering posted this 2 weeks ago

 I dont yet have a response from Lyman. I hope it is reparable. If I had to replace it ?  That is tough. Id guess another Lyman if I could find one at less than retail.  (You can fix anything----if you replace enough parts----up to and including the entire assembly). 

RP

Attached Files

RicinYakima posted this 2 weeks ago

 Yep, had a friend with the title to a 1966 Corvette. Built a new car around it.

Attached Files

  • Liked by
  • Richard Pickering
  • Ken Campbell Iowa
358156hp posted this 2 weeks ago

I've had my Mag 20 go down a few times, usually because of a break in the heating element. At one time Lymans Service Department would sell you parts, since all the new stuff is from China anymore, I kind of doubt they would do that anymore, they wouldn't even sell me replacement handles for ingot moulds. My last MAG 20 failure was the thermostat, which it sounds like could be your pots issue, and it was a total loss. I have cleaned the contacts in the past to get it working again, but it didn't work that last time. I called Lyman and was told to send it in, and the price was around a hundred dollars plus shipping. With shipping both ways it would have been around $150.00 or so.

So I bought a PID controller https://www.omega.com/en-us/resources/pid-controllers, actually I made my own and eliminated the factory bimetal controller that really didn't work well to begin with. I hotwired the pot to be full on, and controlled the temp with the PID and a thermocouple. This has lasted 7-8 years so far with only an occasional thermocouple replacement. If you're not comfortable working with electricity I'd suggest going the Lyman route. Rewiring pots and building PIDs isn't everyones cup of tea. I think I ended up having around $60.00 in building my PID, plus an inexpensive thermocouple. You can also buy premade PIDs from Auber Instruments https://www.auberins.com/ There are also other options for PIDs, I think a couple of guys on the boolits site are selling them as well.But please verify that this is the issure before spending any money of course.

Attached Files

  • Liked by
  • Richard Pickering
Richard Pickering posted this 2 weeks ago

358156,  Thank you for the input. I am not afraid of working with electrical components-----but not live ones.  I have yet to get it apart for the assessment. I have an email in to Lyman; awaiting response.  Let me get an assessment and I'll update.

Thanks. Richard 

Attached Files

fa38 posted this 2 weeks ago

I had an old Lyman 10 pound pot died and it was the rheostat that died and my brother replaced it with one from a popcorn popper unit.  Worked fine with the replacement.  This was 15 to 18 years ago.  Have since purchased a 20 lb pot.

Attached Files

ALYMAN#1 posted this 2 weeks ago

The Auber unit is great, a little pricey, but I couldn't find quality parts here to build one.  Works well with the old Lyman pots.

Attached Files

Richard Pickering posted this 2 weeks ago

Mr Ohm has spoken.  The element is open. The 'stat reads fine. Such is life.    Something else we could have gone all day without.  rp

Attached Files

2kbill posted this 2 weeks ago

Sorry it turned out to be the element.  I've had to open up my mag 20 a couple of times due to corrosion on the element connectors.  I wonder if you could take the element to an appliance repair place and ask them if they could source a suitable replacement?

Region 3

Attached Files

  • Liked by
  • Richard Pickering
Richard Pickering posted this 2 weeks ago

Taking it to an appliance repair would be preferable to having to send it to Lyman.  Thank you. RP

Attached Files

358156hp posted this 2 weeks ago

Hi Richard,

Did you disassemble to pot and look at the element? The reason I ask is that there are two insulated wires coming off the element, and I've had those wires break, plus I even had one that came disconnected from the end of the element itself. It was a standard crimp type connector that you see on electrical butt connectors. Anyway, it may be worth taking a look at the connections and condition of the wiring. The elements were bent to fit the pot, and the real description of them is "tubular heater", and I believe the straight, unbent element was made by a company called "Tempco". Bending one to fit may be a trick though, I don't know if a standard tubing bender would work for this or not. Anyway, for those interested, here's a link to the elements I'm talking about: https://www.tempco.com/Tempco/Resources/10-Tubular-Resources/TubularHeaterCatalogPages.pdf

My surviving new Lyman element is marked "Tempco HE04963 800W 120V A09 14". Maybe you'll get lucky and Lyman will sell you one prebent and ready to install.

 

Good luck!

Bob

Attached Files

  • Liked by
  • Richard Pickering
Richard Pickering posted this 2 weeks ago

Bob, I havent cut into the insulation; but I'm going to do that. Thank you.

 I did email Lyman about parts. Lyman no longer supports the Mag 20. They market a Mag 25 currently.

John Ciofalo replied.  His remarks :  The Mag 20 is long obsolete.  Customer Service is 800 225 9626.  Going further, he says tell C S you are replacing an inoperative Mag 20. You will get the new replacement at 50% off the current price.  

  Richard 

Attached Files

Wheel Weights posted this 2 weeks ago

Current Lymans are best passed up.

 

RCBS is far better, have one for 15 years never a problem and has a far better spout design that Lyman.

 

If anyone sees this post please let me know as I’m not getting PMs.

Attached Files

Ken Campbell Iowa posted this 2 weeks ago

 i see your post.  also sent you a message here from my windows laptop.  usually the problem is either a faulty web browser or a weird cell phone incompatibility.

we are at war with computers and they are winning ...

ken

Attached Files

Shuz posted this 2 weeks ago

When one of my Lyman mag 20's died a few years ago, I bought a used RCBS Promelt and have been very happy with it.

Attached Files

Richard Pickering posted this 2 weeks ago

Bob, I did open it up an in moving it I broke one of the wires from the element. In testing through at the point of element and wire, I still have open. I'm not in desperate need of it. I can wait to possibly buy. Thank you.

Attached Files

Richard Pickering posted this 2 weeks ago

Weights; Why do you recommend against the current Lyman ?  Just curious.  Richard 

Attached Files

358156hp posted this 2 weeks ago

Glad to help Richard. I hope it works out for you.

 

Current Lyman manufacturing is being done in China. The MAG25 had a long list of complaints against it when first released. I rebuilt my MAG20 to avoid buying a MAG 25. One of the primary complaints I've seen involves PID failures. The silly so and so's should have separated the PID (temp controller) from the main housing that also has the pot and heating element in it. I don't think their temp controllers appreciate being that close to a constant 700+ degrees. Mounting it down low in the base would have made a lot of sense.

At least RCBS separated their controller from the pot with a bit more distance on the Pro Melt 2.

Attached Files

Show More Posts
Close